2011年07月06日

書店でも売れています、Vyatta書籍。家でルーティング学習ができる、良い時代ですね

今、ネットワーク書籍で売れているのは、
竹下さんのパケットキャプチャー本改訂版を除けば、
このVyatta書籍くらいです。

Vyatta自体の万能さ、がやはり魅力なのでしょう。

もともと、Zebraやquaggaで、広く知られていたので、
入りやすいし。

BGPやOSPFをこれで動かしながら理解できるのは、
非常に大きいです。




◆オープンソース・ソフトウェアルータVyatta入門 ――実践ルーティングから仮想化まで:
3360円


オープンソース・ソフトウェアルータVyatta入門 ――実践ルーティングから仮想化まで (Software Design plus) [大型本] / 近藤邦昭、松本直人、浅間正和、大久保修一(日本Vyattaユーザー会) (著); 技術評論社 (刊)

ある程度、動かしながら、
問題も解けば、理解がさらに深まる。

そして合格!

徹底攻略 Cisco CCNA 教科書[640-802J][640-816J]対応 ICND2編 (ITプロ/ITエンジニアのための徹底攻略) [単行本] / 株式会社ソキウス・ジャパン (著); 株式会社ソキウス・ジャパン (編集); インプレスジャパン (刊)
徹底攻略 Cisco CCNA/CCENT教科書 ICNDI編 [640-802J][640-822J]対応 (ITプロ/ITエンジニアのための徹底攻略) [単行本] / 株式会社ソキウス・ジャパン (著); 株式会社ソキウス・ジャパン (編集); インプレスジャパン (刊)


●シスコ技術者認定公式ガイド CCNP ROUTE(試験番号:642-902J):7140円

自己投資なしで、甘い未来がくるはずないやん(^ ^)
シスコ技術者認定公式ガイド CCNP ROUTE(試験番号:642-902J) [単行本(ソフトカバー)] / ウェンデル・オドム (著); シスコシステムズ合同会社 (監修); 株式会社トップスタジオ (翻訳); 翔泳社 (刊)

あくまでCCNP合格を目標にしておくべき!





それにしても、暑いですね。

誰や?冷夏かもしれない、とか言ってたのは(苦笑)



◆扇風機






最近は、残業禁止とか残業するな、ということで、
営業時間以外は、クーラーを停止しているところが
増加してますが、もう人間として限界ですよね、
クーラーついてないビルの中は。
posted by アンドレアス at 07:44| Comment(0) | TrackBack(0) | OSPFを動かす | このブログの読者になる | 更新情報をチェックする

2007年06月15日

OSPFマルチエリア2(tshark)

新人、大崎さんのために
キャプチャーの手ほどきです。

Wiresharkを使ってGUIは、
誰でもできますよね?

今日は、
貧弱なスペックのPCを使っていて、
GUIでは使い勝手が悪い時に、
tshark を使えるように・・・・・。





========================

荒:tcpdumpやsnoopというのもあります。

  今日は、tsharkを使いますね。

奥:私達は、よく使ってますよ。

  Wiresharkのコマンド版です。

大:はい。

  よろしくお願いします。

奥:この用紙を参考にコマンドをうってください。

大:はい。



[root@post1 ~]# tshark -D
1. eth0
2. any (Pseudo-device that captures on all interfaces)
3. lo


[root@post1 ~]# tshark -i any -w capture.pcap
tshark: Promiscuous mode not supported on the "any" device.

Capturing on Pseudo-device that captures on all interfaces
(ここにキャプチャー下パケット数が数字で表示)




奥:Ctrl+c キーで、
  キャプチャーをSTOPできますよ。

大:はい。

  コントロールCですね。

奥:ls すると、capture.pcap という

  ファイルが出来てますよ。

大:ほんとですね。

  これがキャプチャーファイルですか。

荒:じゃあ、少しオプションの説明をしますね。


■まとめ

1.tshark -i インターフェース名

キャプチャーするインターフェースを指定できます。

 tshark -D すれば、そのマシンのインターフェースが
 わかります。

 ここでは、anyを使いましたが、
 -i eth0 でも、もちろんOK。

2.tshark -w ファイル名

 これは、キャプチャーした内容を
 ファイルとして保存したい場合に使います。

 .pcapにしたのは、Windows PCで、
  すぐ開けるようにとの配慮です。

3.tshark -i any

 そのまま画面上にキャプチャーしている
 パケットが表示されます。

 snoopに似てますね。


奥:ざっとこんな感じよ。

  で、Windowsですぐ開けるでしょ。

0615.jpg

大:便利ですねぇー。

荒:じゃあ、エリア1のパケットを
  tshark でキャプチャーしてもらいましょう。




■オススメ書籍

パケットキャプチャ入門―LANアナライザWireshark活用術
http://homepage3.nifty.com/sysaho/ccnp.html


Flow Graphなどのラダー表示など、
Wiresharkを完全に使いこなしたい人は
買うべきです。

サーバー系の人は、
キャプチャーしない傾向がありますが、
知ったかぶりせずに、
ちゃんとキャプチャーぐせをつけるべきだと
思います。

posted by アンドレアス at 00:34| Comment(0) | OSPFを動かす | このブログの読者になる | 更新情報をチェックする

2007年06月12日

OSPFマルチエリア1

荒:大崎さーん、始めるでー。

奥:大丈夫よー。

  スタティック設定やらないからー手(パー)

  昨日、「吐くわよ」って言ったので
  怯んでしまったみたい(^^)。

荒:悪い先輩やなぁーわーい(嬉しい顔)

  OSPFやるよー。

大:はい・・・・・。

荒:では、教科書のP210を開けて下さい。

奥:とうとう、教科書になりましたね(笑)。


■教科書

 「要点解説 IPルーティング入門」(税込み \3,360) P210〜


荒:マルチエリアをやりましょう。

  今まで、エリア0(area 0) って設定してましたよね。

  あれをarea 1とかarea 2にしていきます。

奥:キャプチャーもするんですね。

荒:はい。

  このブログで作るような小さなネットワークでは、
  エリアは0だけで十分なんですけどね。

奥:ルーティングテーブルが、1000行もあるような
  規模のでかい会社だと思い込むと。


大:はい。

荒:手始めに、軽くコマンドを確認しましょう。

  じゃあ、OSPF初めての大崎さん、ヨロシク。

  パスワード以外の設定は、全部消してますから。


大:はい。

  bind1でいいですね?

奥:うん。

大:では・・・。


[root@bind1 ~]# telnet 127.0.0.1 2604
Trying 127.0.0.1...
Connected to bind1.example.com (127.0.0.1).
Escape character is '^]'.

Hello, this is Quagga (version 0.98.6).
Copyright 1996-2005 Kunihiro Ishiguro, et al.


User Access Verification

Password:
bind1> en
Password:
bind1#


大:えーっと、うーーん・・・。


bind1# conf t
bind1(config)# router ospf
bind1(config-router)# network 192.168.1.0/24 area 1


奥:うん。

  さすが、私の後輩。。

荒:以前、メルマガで言いましたが、

  OSPFのnetworkコマンドは、

  OSPFを有効化させるインターフェースを指定する

  ことになります。

  今で言うと、192.168.1.14 とか 192.168.1.110とか
  192.168.1.0/24に含まれるIPアドレスを持つ
  インターフェースがあれば、そこで
  OSPFが有効化されます。


  なので、192.168.2.1というIPアドレスを持つ
  インターフェースがあっても、OSPFは
  有効にならないんですね。

奥:うん。

  今になってようやく、
  あの時の話が理解できましたよ。


荒:補足ですが・・・・area 1というように
  エリアを数字で打ち込むのが、普通ですね。


  下記を見てもらうとわかるように


bind1(config-router)# network 192.168.1.0/24 area
<0-4294967295> OSPF area ID as a decimal value
A.B.C.D OSPF area ID in IP address format


  IPアドレス形式でもエリア設定は可能です。

  まあ、誰もこういう打ち込みはしないと思いますが・・・。


大:試しにうってみます。


bind1(config-router)# network 192.168.1.0/24 area 0.0.0.1
There is already same network statement.


  あっ、設定済だから、同じって出ましたね。


荒:よし。

  では、明日は、久しぶりにキャプチャーするかな?





posted by アンドレアス at 23:51| Comment(0) | OSPFを動かす | このブログの読者になる | 更新情報をチェックする

2007年06月01日

OSPFの応用・・再配送(後編4ラスト)

奥:よろしくお願いします。

  こんな時間に(^^)。

荒:とっとと、帰りましょうわーい(嬉しい顔)

  で、できましたか?

  まあ、設定するネットワークは
  いくつか思いつくもので良かったわけですけど。


■構成図

0526.jpg


奥:はい。

  黄色いルーターに、
192.168.1.0/24 192.168.2.101 コマンドで
  スタティックルートを設定します。

  下のように。

■回答

bind1.example.com# conf t

bind1.example.com(config)# ip route 192.168.1.0/24 192.168.2.101

bind1.example.com(config)# exit


荒:うん。

  いくつか答えがありますよね。

  下記もありだし。

bind1.example.com(config)# ip route 192.168.1.0/24 192.168.2.40
  
  直接ホストルーティングを切ってもいいよね。

bind1.example.com(config)# ip route 192.168.1.14/32 192.168.2.101



奥:はい。

  だいぶん、わかってきました。

荒:今日の問題は、簡単だったと思うよ。

  ただね、こういう問題では正解できても、
  対象が変わったら、途端にできなくなる人も
  多いからね。


  サーバーのメンテナンス用で
  バックアップ回線を引いて、
  そこからサーバーにつなげる、というケース。


  今でも、地方では、あるからね。

  で、サーバーにルーティング設定するって
  全く意識のないってケースよくあるからなぁー。


  「あれ、つながらない」とか言って、
  また、現地へ行くみたいな(^^)


  で、問題だけは、ちゃんと正解するという(^^)。


  なので、スタティック設定だからって
  なめてかからないように。


  それが自分の身を守る知恵でもあるから。


奥:はい。

  体験者から聞くと、よくわかります(^^)


荒:じゃあ、次は、
  この例を使って、
  アドミニストレーティブディスタンス値を
  設定してみます。


奥:ディスタンス値ですか?

荒:ではP58〜をよく読んでおいてください。

奥:は〜〜い。


■参考
 「要点解説 IPルーティング入門」P58

 http://homepage3.nifty.com/sysaho/ccnp.html


posted by アンドレアス at 22:57| Comment(0) | OSPFを動かす | このブログの読者になる | 更新情報をチェックする

2007年05月31日

OSPFの応用・・再配送(後編3)

いつまで続くのか・・・後編わーい(嬉しい顔)

さあ、カンの鋭い人は、
今日の後編3で話す内容に気づいているかも
しれませんねぇー。

=========================================

荒:図のIPアドレス間違ってたね。

  192.168.2.254/24に修正しました。

奥:redhatのstaticも
  図を見ながら、設定したから
  間違えてしまいました。

  ルーティングテーブルも修正したので、
  後編2を見直して下さい。


荒:さて、話の続きです。

  「再配送」はできたんですが、
  これだけで、2つの会社間の通信は
  できますか?

  というのが、今日の宿題です。


奥:えっ?何ですか?

  もう1回お願いします。

荒:redhatやtvに対しての設定はできましたよね。

  bind1ルーターも、
  OSPFで、172.16.0.0/16のネットワークに
  たどりつくには、
  どこへ行けばいいか、わかっています。

奥:はい。

荒:でも、自分だけわかっているけど、
  相手は、何もわかっていない。

奥:わかっていない?

  あー、OSPFが動いていない、
  黄色のルーターですね。

  そっかー。

  じゃあ、お互いの会社間で
  まだ通信はできない。


  なるほど。

荒:じゃあ、もうわかったと思うけど、
  宿題です。


■お互いの会社間で通信を行いたい。

 1.どのルーターに

 2.どんな設定を行えばよいか

 3.但し、黄色ルーターは、
   RIPやOSPFなど
   ダイナミックルーティングを使えないことと
   する。
   (そんなショボイルーター、今時ないけど・・わーい(嬉しい顔)
  


奥:なるほど。

  最後まで通信確認を行わないと、ウカレてちゃ
  ダメなんですねぇー。わーい(嬉しい顔)



つづく・・・・・。

posted by アンドレアス at 22:06| Comment(0) | OSPFを動かす | このブログの読者になる | 更新情報をチェックする

2007年05月27日

OSPFの応用・・再配送(後編2)

前編・後編なら、
本当は昨日で終わりなんですがわーい(嬉しい顔)
このブログには、そんな常識も通用せず。

後編2・3・4と、
どんどん、後編が続きそう・・(^^)/
============================================

荒:では、タイプ1とタイプ2を学びます。

  僕は、実際に企業での再配送設定を見てますが、
  タイプ1のケースしか見たことないですね。

  まず、実際に設定してみましょう。

  で、違いを把握しておきましょう。

奥:はい。


荒:じゃあ、昨日やった設定は全部なかったものと
  して下さい。


  で、下記の設定を順番に行ってください。

 
奥:はい。

  えーーーっと・・・。

0526.jpg


■順番
 1.今回は、ホスト名:redhatのみ。

   172.16.0.0/16へのスタティックルートを
   設定する。

 2.redhatのOSPFで、再配送の設定を行う。

   コマンドは、redistribute static

 3.redhatのOSPFで、再配送の設定を行う。

   但し、タイプ1でメトリック4とする。

redhat# conf t
redhat(config)# router ospf
redhat(config-router)# redistribute static metric-type 1 metric 4


 4.redhatのOSPFで、再配送の設定を行う。

   但し、タイプ2でメトリック3とする。

redhat# conf t
redhat(config)# router ospf
redhat(config-router)# redistribute static metric-type 2 metric 3


奥:できました。

  なるほどー。

荒:じゃあ、
  順番にbind1のルーティングテーブルを
  確認しましょう。

  
■昨日のルーティングテーブル
 (今日の2ですね)
bind1.example.com# show ip route
Codes: K - kernel route, C - connected, S - static, R - RIP, O - OSPF,I - ISIS, B - BGP, > - selected route, * - FIB route
(他省略)
O>* 172.16.0.0/16 [110/20] via 192.168.1.101, eth0, 00:00:07


■3のルーティングテーブル
bind1.example.com# show ip route
Codes: K - kernel route, C - connected, S - static, R - RIP, O - OSPF,I - ISIS, B - BGP, > - selected route, * - FIB route
O>* 172.16.0.0/16 [110/24] via 192.168.1.101, eth0, 00:00:42


■4のルーティングテーブル
bind1.example.com# show ip route
Codes: K - kernel route, C - connected, S - static, R - RIP, O - OSPF,I - ISIS, B - BGP, > - selected route, * - FIB route
O>* 172.16.0.0/16 [110/3] via 192.168.1.101, eth0, 00:00:05

荒:どうですか?

  タイプ1と2の違いが、
  なんとなくわかりますか?

奥:タイプ1は、わかったような気がします。

  パケットが通っていく中で
  ルーターの出口でお金(コスト値)を払う
  イメージですよね。

  redistributeの時は、
  出口でもお金を払うし、
  ルーターの中を通っている時
  メトリックで指定された値を払う、感じ。



  あってます?

荒:うん。

  そんなイメージですよね。

  結局、宛先のネットワークにたどりつくために、
  黄色のルーターの出口でもお金(コスト)を
  払わないと、たどりつけないでしょ、

  ということですね。

  今は、全部宛先があるので、
  「ルーターの出口を出る」わけですが、
  やがて、出口を出ないケースも登場します。

  その時、もう1度思い出して欲しいですね。

  「OSPFは、出口で、お金(コスト)を払う」と。


奥:はい。

  タイプ2は・・・・・

  redistributeで指定したお金を払えば、
  何回ルーターの出口を通っても、
  もう、お金を払う必要は、ないイメージ。


  あってます?

荒:そうそう。

  あってるよ。

奥:手(グー)


■参考
 「要点解説 IPルーティング入門」P564,565 OSPFへの再配布など

 http://homepage3.nifty.com/sysaho/ccnp.html
  


■CCNA受験を目標としている方への参考

 重くて分厚い本ですがわーい(嬉しい顔)
 今もこれがNo1です。
 実務でも役立つから。

 「図解CCNA対策教本 スキルアップ問題集」
 http://homepage3.nifty.com/sysaho/ccna.html



posted by アンドレアス at 11:43| Comment(0) | OSPFを動かす | このブログの読者になる | 更新情報をチェックする

2007年05月26日

OSPFの応用・・再配送(後編)

初心者レベルを超えることができない人が、
一番理解に苦しむのが、再配送。

でも、実際にquaggaを動かしてみれば、
すぐに再配送の動作も
会得、体得できるはずです。

手を動かす!これに尽きます!
========================================


荒:ではさっそく、始めましょう!

奥:よろしくお願いします。

荒:スタティックルートをOSPFに再配送します。

  はじめに構成図を見て下さい。

0526.jpg


  黄色のルーターが登場しました。
  実は、このルーターは、・・・


  小さな企業を買収・合併した。
  ↓
  自社のネットワークに、
  接続する事になった。
  ↓
  自社は、OSPFでルーティングしている。
  なので、合併会社のルーターでも
  OSPFを動かしてもらおう。
  ↓
  ところが、買収した会社のルーターは、
  OSPFを話せない!

  合併会社は、規模も小さかったので、
  スタティックルート設定でルーティングしていた。
  ↓
  仕方ない。
  じゃあ、自社ルーターで
  スタティック設定を追加して、
  OSPFに再配送するか・・・


奥:なるほど。

  そういうストーリーですか。

  フムフム・・・。


荒:じゃあ、具体的に再配送をやりましょうか。

  順番です。

  1.スタティックルートを設定する

    redhatとtv2の両方で再配送を行ってみましょう。

  2.OSPFでredistributeコマンドを使用する。

    redhatとtv2の両方で再配送を行ってみましょう。

  3.bind1 のルーティングテーブルを確認する。



奥:では、さっそく。


1.スタティックルートを設定する

■redhat(ポートは、2601ですよ)
redhat.example.com# conf t
redhat.example.com(config)# ip route 172.16.0.0 255.255.0.0 192.168.2.254
redhat.example.com(config)# exit
redhat.example.com#

■tv2(ポートは、2601ですよ)
tv2.example.com# conf t
tv2.example.com(config)# ip route 172.16.0.0 255.255.0.0 192.168.2.254
tv2.example.com(config)# exit
tv2.example.com#


2.OSPFでredistributeコマンドを使用する

■redhat(ポートは、2604ですよ)
redhat# conf t
redhat(config)# router ospf
redhat(config-router)# redistribute static
redhat(config-router)# end
redhat#

■tv2(ポートは、2604ですよ)
tv2.example.com# conf t
tv2.example.com(config)# router ospf
tv2.example.com(config-router)# redistribute static
tv2.example.com(config-router)# end
tv2.example.com#


3.bind1 のルーティングテーブルを確認する。

bind1.example.com# show ip route
Codes: K - kernel route, C - connected, S - static, R - RIP, O - OSPF,I - ISIS, B - BGP, > - selected route, * - FIB route

K>* 0.0.0.0/0 via 192.168.1.1, eth0
C>* 127.0.0.0/8 is directly connected, lo
O>* 172.16.0.0/16 [110/20] via 192.168.1.40, eth0, 00:00:07
* via 192.168.1.101, eth0, 00:00:07

O 192.168.1.0/24 [110/10] is directly connected, eth0, 00:31:06
C>* 192.168.1.0/24 is directly connected, eth0
O>* 192.168.2.0/24 [110/20] via 192.168.1.40, eth0, 00:29:26
* via 192.168.1.101, eth0, 00:29:26



奥:なるほど。

  192.168.1.101、192.168.1.40の
  どちらの道を通っても良い、と。

  ということは、
  「なぜ、再配送するのか」という
  背景事情があって初めて
  再配送という方法を使うんですね。

荒:そうそう。

  ところで、こういう設定をしましたが、
  実際に使われている設定は、もう少し
  細かいです。


  明日は、タイプ1、タイプ2というものを
  設定してもらいますね。


奥:はい。

  だんだんCCNPのBSCIが見えて来たような・・。

荒:EIGRPもあるで。わーい(嬉しい顔)

奥:あ、そっかー。がく〜(落胆した顔)


■参考
「要点解説 IPルーティング入門」P556

 http://homepage3.nifty.com/sysaho/ccnp.html

  
posted by アンドレアス at 08:01| Comment(0) | TrackBack(1) | OSPFを動かす | このブログの読者になる | 更新情報をチェックする

2007年05月25日

OSPFの応用・・・再配送(前編)

(たまには、休みたいんですが・・・By Araki&Okudaわーい(嬉しい顔)


奥:すみません。わーい(嬉しい顔)
  
  お願いします。

荒:はい。

  再配送ですが、
  ここでは、OSPFを使っての再配送を
  実際にやってもらいます。


奥:はい。

荒:言葉だけでは、わかりにくいと思います。

  OSPFを使って実際にやってみましょう。

  「OSPFに再配送」

  と言った時、

  OSPFに、OSPF以外の別のプロトコルの
  ルーティング情報を送り込む。

  流し込む、ということになります。

  わかりますか?


奥:うーーーん、イマイチわかりません。

荒:OSPFとRIPは、違いますよね。

  OSPFとRIPは、お互いに情報交換はできません。

奥:はい。

  そうですねー。

荒:なので、どちらかが相手に合わしてあげる
  必要があります。

奥:はい。

荒:相手に合わしてあげるので、
  相手がどういう人なのか、
  どういう仕組みなのかを理解した上で、
  合わせないといけないですよね?

奥:そうですね。


荒:RIPがOSPFに合わせてあげるには、
  OSPFが出口でお金を払うプロトコルだと
  いう、一番大事なところに、
  合わせないといけません。

奥:はい、はい。

荒:すると、RIPは、なんとかして
  経路情報をコスト値で伝えるように
  努力しないといけません。

奥:うーーん。

荒:英語を日本語に翻訳する時に、
  ある決まった変換が行われます。

  同じように、RIPをOSPFに合わせる時
  ある決まった変換が行われます。


奥:うーーーん。

  なんとなく、わかったような・・・。



■参考
「要点解説 IPルーティング入門」P556

 http://homepage3.nifty.com/sysaho/ccnp.html



posted by アンドレアス at 22:24| Comment(0) | TrackBack(0) | OSPFを動かす | このブログの読者になる | 更新情報をチェックする

2007年05月24日

OSPFの基本・・コスト値(後編2)

(昨日までのあらすじ)

OSPFのコスト値を変えて、
ルーティングテーブルの変化を確認した2人。

続いて、
tv2の方をパケットが流れるように、という課題が
与えられた・・・・。

さあ、どうなる、バンビ!
(違うって (^^) )

==============================

荒:どう?

  できた?

奥:はい。

  redhatのコスト値を100にしてみました。


redhat# conf t
redhat(config)# interface eth1
redhat(config-if)# ospf cost 100




■設定変更前のルーティングテーブル
bind1.example.com# show ip route
Codes: K - kernel route, C - connected, S - static, R - RIP, O - OSPF,I - ISIS, B - BGP, > - selected route, * - FIB route

K>* 0.0.0.0/0 via 192.168.1.1, eth0
C>* 127.0.0.0/8 is directly connected, lo
O 192.168.1.0/24 [110/10] is directly connected, eth0, 00:52:16
C>* 192.168.1.0/24 is directly connected, eth0
O>* 192.168.2.0/24 [110/14] via 192.168.1.101, eth0, 00:02:33


■設定変更後のルーティングテーブル
bind1.example.com# show ip route
Codes: K - kernel route, C - connected, S - static, R - RIP, O - OSPF,I - ISIS, B - BGP, > - selected route, * - FIB route

K>* 0.0.0.0/0 via 192.168.1.1, eth0
C>* 127.0.0.0/8 is directly connected, lo
O 192.168.1.0/24 [110/10] is directly connected, eth0, 00:53:22
C>* 192.168.1.0/24 is directly connected, eth0
O>* 192.168.2.0/24 [110/20] via 192.168.1.40, eth0, 00:00:04


荒:tv2のコスト合計が20。

  redhatのコスト合計が110.

奥:tv2を通っていくと、
  tv2を出て行くときに、20円だけ払えばいい。

  安いから、tv2を通ろう!

  こういうイメージですね。

荒:うん。

奥:やった!手(チョキ)

  最後に、絵もつけておきました。

0524.JPG



荒:さーて、そろそろ、再配送やろうかな。

  redistribute(リディストリビュート)とも
  言います。

  これを押さえておけば、CCNPは大丈夫だよ。

  きっと。

奥:頑張りまーーす!手(グー)


■参考
「要点解説 IPルーティング入門」P194,P231など
「とこトンやさしいIPルーティング」P183,P220など

 http://homepage3.nifty.com/sysaho/ccnp.html

posted by アンドレアス at 23:38| Comment(0) | TrackBack(0) | OSPFを動かす | このブログの読者になる | 更新情報をチェックする

OSPFの基本・・コスト(後編)

荒:redhat(192.168.1.201/24)の
  コスト値を下げてみましょう。

  安くしちゃいます。

奥:出口で払う料金を値下げしたイメージですね。


redhat# conf t
redhat(config)# interface eth1
redhat(config-if)# ospf cost 1
redhat(config-if)# end
redhat#


奥:1になりましたねー。

redhat# show ip ospf interface eth1
eth1 is up
Internet Address 192.168.2.101/24, Broadcast 192.168.2.255, Area 0.0.0.0
Router ID 192.168.3.101, Network Type BROADCAST, Cost: 1
Transmit Delay is 1 sec, State DR, Priority 1
Designated Router (ID) 192.168.3.101, Interface Address 192.168.2.101
Backup Designated Router (ID) 192.168.2.201, Interface Address 192.168.2.201
Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
Hello due in 00:00:01
Neighbor Count is 2, Adjacent neighbor count is 2



荒:bind1のルーティングテーブルを見て下さい。

奥:はい。

  あっ!変わってます。

  なるほどー。

  そっかー。

  出口でお金を払うプロトコルなので、

  コスト値を変化させれば、
  パケットはお金の安い方の道(ルート)を
  通って行くんですね。

bind1.example.com# show ip route
Codes: K - kernel route, C - connected, S - static, R - RIP, O - OSPF,
I - ISIS, B - BGP, > - selected route, * - FIB route

K>* 0.0.0.0/0 via 192.168.1.1, eth0
C>* 127.0.0.0/8 is directly connected, lo
K>* 169.254.0.0/16 is directly connected, eth0
O 192.168.1.0/24 [110/10] is directly connected, eth0, 00:37:08
C>* 192.168.1.0/24 is directly connected, eth0
O>* 192.168.2.0/24 [110/11] via 192.168.1.101, eth0, 00:01:40



奥:変化前、変化後を念のため、
  再確認しておきましょう。


■コスト値変更ビフォー
O>* 192.168.2.0/24 [110/20] via via 192.168.1.101, eth0, 00:00:43

■コスト値変更アフター
O>* 192.168.2.0/24 [110/11] via 192.168.1.101, eth0, 00:01:40


荒:ルーターの出口でお金をとられる、

  って意味が体感できたかな?

奥:はい。

  安い方がいい道(ルート)って意味もわかりました。

荒:自分がパケットになったと思って

  1.ルーターbind1(192.168.1.14/24)の中にいる

  2.192.168.2.0/24へ行かなきゃならない

  3.bind1のインターフェースを出るときに
    10円のコストを払う

  4.通るルートは、redhatがいい。

    出口で払うお金は1円になってるし。

    tv2の方を通ると10円だし。
    高いよ。

  5.redhatに入る時は、お金は払わなくてよし。

    出るときに払う。

    いよいよ出るぞ。1円払って、合計11円

奥:合計11円のコスト。

  これが、上のルーティングテーブルの11ですね。

  大分わかった気がします。


荒:では、問題です。

  ・コスト値は、いくつに設定してもよい。

  ・redhatでも、tv2(192.168.1.40/24)の
   どちらのルーターのインターフェースを
   変更してもよい。  

  ・192.168.2.0/24へのパケットは、
   ホスト名:tv2(192.168.1.40/24)を通るように。

奥:やってみます。手(グー)


■参考
「要点解説 IPルーティング入門」P194,P231など
「とこトンやさしいIPルーティング」P183,P220など

 http://homepage3.nifty.com/sysaho/ccnp.html

posted by アンドレアス at 07:02| Comment(0) | TrackBack(0) | OSPFを動かす | このブログの読者になる | 更新情報をチェックする

2007年05月23日

OSPFの基本・・コスト値(前編)

荒:ども、お待たせしました。

奥:もう、大丈夫ですか?

荒:うーーん、どうも肩こりなのかなぁー。

  さっさと始めて帰りましょう(^^)/

奥:バンビーノ見たいし・・。

  では、構成図です。



0523.JPG


荒:非常に簡単な構成です。

  さて、一番左のルーターに注目して下さい。

  ルーティングテーブルで、192.168.2.0/24は
  どういう見え方をするか、わかりますか?


奥:いいえ。

  192.168.2.0/24が、
  あることくらいしか、わかりません。


荒:おとつい話しましたが、

  「OSPFは、ルーターの出口でお金(コスト)を
   払うプロトコル」

  と言いました。

  これを実際に体感してもらおうと思います。

  一番左のルーターが、いつもの
  bind1です。

  show ip route してみましょう。



bind1.example.com# show ip route
Codes: K - kernel route, C - connected, S - static, R - RIP, O - OSPF,
I - ISIS, B - BGP, > - selected route, * - FIB route

K>* 0.0.0.0/0 via 192.168.1.1, eth0
C>* 127.0.0.0/8 is directly connected, lo
K>* 169.254.0.0/16 is directly connected, eth0
O 192.168.1.0/24 [110/10] is directly connected, eth0, 00:27:00
C>* 192.168.1.0/24 is directly connected, eth0
O>* 192.168.2.0/24 [110/20] via 192.168.1.40, eth0, 00:00:43
* via 192.168.1.101, eth0, 00:00:43




奥:192.168.2.0/24への道(ルート)は、
  2つありますね。

  1つは、192.168.1.40を通る道。

  もう1つは、
  ホスト名:redhat(192.168.1.101)を通る道。


荒:192.168.2.0/24の右に、
  [110/20] とありますよね。

  この20が、宛先にたどりつくまでの
  コスト値の合計です。

  20円かかる、と考えてもいいですし、
  20ドルでもいいです。

奥:はい。

荒:今は、この2つの道は、同じコストが
  かかるんですね。

  ここで、コスト値の確認方法を先に
  覚えて下さい。

  これですよ・・・。

奥:えーっと、これですね。


■redhatの場合

# show ip ospf interface

eth0 is up
Internet Address 192.168.1.101/24, Broadcast 192.168.1.255, Area 0.0.0.0
Router ID 192.168.3.101, Network Type BROADCAST, Cost: 10
Transmit Delay is 1 sec, State DR, Priority 1
Designated Router (ID) 192.168.3.101, Interface Address 192.168.1.101
Backup Designated Router (ID) 192.168.2.40, Interface Address 192.168.1.40
Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
Hello due in 00:00:08
Neighbor Count is 2, Adjacent neighbor count is 2
eth1 is up
Internet Address 192.168.2.101/24, Broadcast 192.168.2.255, Area 0.0.0.0
Router ID 192.168.3.101, Network Type BROADCAST, Cost: 10
Transmit Delay is 1 sec, State DR, Priority 1
Designated Router (ID) 192.168.3.101, Interface Address 192.168.2.101
Backup Designated Router (ID) 192.168.2.201, Interface Address 192.168.2.201
Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
Hello due in 00:00:05
Neighbor Count is 2, Adjacent neighbor count is 2


奥:10って出てますね。

荒:はい。

  Ciscoルーターだと、
  100MBのFastEthernetのコスト値は、
  1なんですが、まあ、その辺は、臨機応変に。

奥:CCNA受ける人は、間違わないように
  しておかないといけないですね。

荒:そのために、毎回毎回
  書籍をオススメしているわけなんですけどね。



■参考・・・CCNA受験予定者でも、使えます。iprouting.jpg
「要点解説 IPルーティング入門」P194,P231など
価格:¥3,360(税込)
出版社:ソフトバンククリエイティブ


http://homepage3.nifty.com/sysaho/ccnp.html

posted by アンドレアス at 23:29| OSPFを動かす | このブログの読者になる | 更新情報をチェックする

2007年05月18日

OSPFの基本、ネイバーが消える時

奥:今週最後ですね。

荒:じゃあ、サッサと片付けて
  帰りましょう!

  今日は、ネイバーテーブルから
  ネイバーが消える、ことを確認します。


  消える理由は、トラブル発生ですね。

奥:ハードウェアトラブルとか。

荒:はい。

  他にも、LANケーブルが抜けたとか。

奥:私達の会社では、そんなことはありませんが、
  お客さんのところでは、ありますよね(笑)。


荒:そうそう。

  ありえないはずなんだけどね(^^)。

奥:では、さっそくネイバーテーブルを見ましょう。


bind1# show ip ospf neighbor

Neighbor ID Pri State Dead Time Address
192.168.2.101 1 Full/Backup 00:00:32 192.168.1.101
192.168.1.201 1 Full/DROther 00:00:33 192.168.1.201

Interface RXmtL RqstL DBsmL
eth0:192.168.1.14 0 0 0
eth0:192.168.1.14 0 0 0


奥:ホスト名:jisaku1 を起動させています。

  192.168.1.201が、jisaku1です。

荒:ちなみに、私の私物マシンなんですけど・・。

奥:ご提供ありがとうございます。(^^)


荒:既に、192.168.1.0/24 のセグメントには、

  DR :bind1.example.com
  BDR:redhat.example.com


  DRもBDRも存在してます。

  なので、それ以降に起動してきた、
  OSPFルーター (jisaku1)は、
  DROther として表示されます。


奥:DRやBDRではないですよ、ということですね。


荒:はい、そうです。

  では、参考までに、
  他のマシンのネイバーテーブルも見ます。



redhat# show ip ospf neighbor

Neighbor ID Pri State Dead Time Address
192.168.1.14 1 Full/DR 00:00:39 192.168.1.14
192.168.1.201 1 Full/DROther 00:00:30 192.168.1.201

Interface RXmtL RqstL DBsmL
eth0:192.168.1.101 0 0 0
eth0:192.168.1.101 0 0 0



jisaku.example.com# show ip ospf neighbor

Neighbor ID Pri State Dead Time Address
192.168.1.14 1 Full/DR 00:00:37 192.168.1.14
192.168.2.101 1 Full/Backup 00:00:37 192.168.1.101

Interface RXmtL RqstL DBsmL
eth0:192.168.1.201 0 0 0
eth0:192.168.1.201 0 0 0


荒:では、ホスト名:redhatの
  LANケーブルを抜きますよ。

(抜いた)


bind1# show ip ospf neighbor

Neighbor ID Pri State Dead Time Address
192.168.2.101 1 Full/Backup 00:00:39 192.168.1.101
192.168.1.201 1 Full/DROther 00:00:31 192.168.1.201

Interface RXmtL RqstL DBsmL
eth0:192.168.1.14 0 0 0
eth0:192.168.1.14 0 0 0


bind1# show ip ospf neighbor

Neighbor ID Pri State Dead Time Address
192.168.2.101 1 Full/Backup 00:00:31 192.168.1.101
192.168.1.201 1 Full/DROther 00:00:33 192.168.1.201

Interface RXmtL RqstL DBsmL
eth0:192.168.1.14 0 0 0
eth0:192.168.1.14 0 0 0


(途中省略)

荒:今、redhatから、
  Helloパケットが送信されていない
  状態です。

  Dead Timeは正常時、00:00:30になったら、
  再び00:00:40からカウントします。

奥:でも、今は、Helloが来ないので、
  00:00:29、28、27という具合に、
  1秒ずつ減っていくんですね。

荒:そうこう言っている間に
  さあ、後1秒・・・。


bind1# show ip ospf neighbor

Neighbor ID Pri State Dead Time Address
192.168.2.101 1 Full/Backup 00:00:01 192.168.1.101
192.168.1.201 1 Full/DROther 00:00:32 192.168.1.201

Interface RXmtL RqstL DBsmL
eth0:192.168.1.14 0 0 0
eth0:192.168.1.14 0 0 0


奥:ゼロー。


bind1# show ip ospf neighbor

Neighbor ID Pri State Dead Time Address
192.168.2.101 1 Full/Backup 00:00:00 192.168.1.101
192.168.1.201 1 Full/DROther 00:00:31 192.168.1.201

Interface RXmtL RqstL DBsmL
eth0:192.168.1.14 0 0 0
eth0:192.168.1.14 0 0 0


奥:消えました。

  192.168.1.201が、Backup(BDR)になりましたね。


bind1# show ip ospf neighbor

Neighbor ID  Pri State Dead Time Address
192.168.1.201 1 Full/Backup 00:00:40 192.168.1.201

Interface RXmtL RqstL DBsmL
eth0:192.168.1.14 0 0 0


荒:ということで、

  ネイバーテーブルから完全に消えるまでの時間は、
  30秒から40秒ということです。


  つまり、それまでは、経路も変化しないということです。


  下記コマンドをうつと、40秒の値が表示されます。

  Dead 40という部分です。


bind1# show ip ospf interface
eth0 is up
Internet Address 192.168.1.14/24, Broadcast 192.168.1.255, Area 0.0.0.0
Router ID 192.168.1.14, Network Type BROADCAST, Cost: 10
Transmit Delay is 1 sec, State DR, Priority 1
Designated Router (ID) 192.168.1.14, Interface Address 192.168.1.14
No backup designated router on this network
Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
Hello due in 00:00:07
Neighbor Count is 0, Adjacent neighbor count is 0
lo is up
OSPF not enabled on this interface
sit0 is down
OSPF not enabled on this interface




奥:40秒は、ルータDeadインターバル、です。

  詳しくは、下記書籍をご覧下さい。

  おつかれさまでしたぁー。

荒:おつかれさまぁー。来週もヨロシク!手(パー)



■参考:ルータDeadインターバル
    ★CCNA受験予定者でも、使えます。
iprouting.jpg
「要点解説 IPルーティング入門」(P176〜)
価格:¥3,360(税込)
出版社:ソフトバンククリエイティブ
posted by アンドレアス at 23:50| OSPFを動かす | このブログの読者になる | 更新情報をチェックする

2007年05月17日

OSPFの基本、ネイバー・アジャセンシー(後編)

荒:こんばんは、続きです。

奥:よろしくお願いします。

荒:早く帰りましょう!わーい(嬉しい顔)


  ネイバー関係は、うまくできました。

  そこで、
  DB Descriptionパケットを送信してますね。
  (書籍では、DBDパケットと記述してます)


ospfhello4.JPG



奥:Exchange State状態ですね。

  bind1が、マスター と呼ばれる方ですね。

  redhatが、スレーブで、
  同じように、
  DBDパケットを送信していますね。


荒:この後、LSRパケットに対して、
  LSUパケットを送信しています。


ospfhello6.JPG


奥:今は2台ですが、
  2台とも、自分のリンクデータベースに
  リンクの情報(エントリ)を追加できたところで、
  同期できた、わけですね。


荒:それが、Full(フル)状態です。

  このFull状態、は覚えておきましょう。


奥:以降は、10秒毎に
  各々のルーターは、Helloパケットを
  はいてますね。


荒:Helloを出し続けることで、
  俺は生きてるよ、と知らせているわけです。


奥:皆さんもキャプチャーされたパケットと
  書籍を見比べながら、LSAの中をのぞいて
  見ましょう。

  では、今日は、この辺で・・・。手(パー)



■参考

「要点解説 IPルーティング入門」(P186〜P188)
「とこトンやさしいIPルーティング」(P175〜P178)


 http://homepage3.nifty.com/sysaho/ccnp.html


「パケットキャプチャ入門―LANアナライザWireshark活用術」も
参考になります。

posted by アンドレアス at 21:08| Comment(0) | TrackBack(0) | OSPFを動かす | このブログの読者になる | 更新情報をチェックする

2007年05月16日

OSPFの基本、ネイバー・アジャセンシー(前編)

奥:では、ホスト名:redhat を
  ネットワークに参加させます。


荒:ospfdが動作し始める前に、
  今日のポイントです。

  1.ネイバーテーブルの変化を見る。

  2.Wiresharkのキャプチャーパケットを見て、
    どこが、どう変化するかを確かめる。


  OSPFパケットの中身を見る人も少ないですね。

  こういう機会に、確認する癖をつけましょう。

奥:はい。

  では、構成図を確認しておきましょう。


■構成図(今までと同じです)

ホスト名:bind1
eth0: 192.168.1.14/24
|
|
スイッチングハブ
|
|
eth0: 192.168.1.101/24
ホスト名:redhat eth2:192.168.3.101/24
eth1: 192.168.2.101/24
|
|



奥:あっ!
  Full状態になりましたね。


bind1# show ip ospf neighbor

NeighborID Pri State Dead Time Address
192.168.1.101 1 Full/Backup 00:00:33 192.168.1.101

(見やすくするため改行しました)

Interface     RXmtL RqstL DBsmL
eth0:192.168.1.14  0 0 0


荒:redhatの方も見ておきましょう。
  こっちが、DR(ディーアール)ですね。


redhat# show ip ospf neighbor
NeighborID Pri State Dead Time Address
192.168.1.14 1   Full/DR 00:00:34 192.168.1.14

(見やすくするため改行しました)
Interface     RXmtL RqstL DBsmL
eth0:192.168.1.101  0 0 0




奥:キャプチャーパケットを見ると・・。

ospfhello2.JPG


荒:「こんにちは、自分は、OSPFを話しますよ」って
  呼びかけてますね。

  あて先が、224.0.0.5 マルチキャストで。

奥:RIPのように、
  ブロードキャストではない、と。

荒:誰にでも、アタックしているわけではない、
  プロトコルですね。

  話くらいしてもいい、
  という人(ルーター)と
  ネイバーになろうとするわけですね。


奥:で、話のきっかけをつかんだのが
  これですねわーい(嬉しい顔)


ospfhello3.JPG


荒:一番下に、Active Neighborってありますね。

  うまくネイバー関係になれた。(^^)

  この後、電話番号やメールアドレス・・、
  もとい、リンク情報の交換が始まります。

奥:つづきは、明日・・・・。手(パー)

  自分のPCでキャプチャーしている方は、
  下記を読みながら、パケット確認すると
  理解が深まると思います。


■参考

「要点解説 IPルーティング入門」(P172〜)
「とこトンやさしいIPルーティング」(P167〜)




「パケットキャプチャ入門―LANアナライザWireshark活用術」
 http://homepage3.nifty.com/sysaho/ccnp.html

 画面を見ている人は、わかると思いますが、
 OSPFパケットだけ表示させてます。

 簡単なことですけど、こういう基本レベルから
 やさしく解説してくれている本です。

 新入社員の人や、
 ネットワークエンジニアビギナーな方は、
 有効な機能は、すべて使えるようにしておくべきです。



posted by アンドレアス at 23:28| Comment(0) | TrackBack(0) | OSPFを動かす | このブログの読者になる | 更新情報をチェックする

2007年05月15日

OSPFの基本、Helloパケットは10秒間隔

★★★前回までのあらすじ

RIPにハマリつつ
ついに、BGP,OSPF,RIPを
全てまともに動かした2人。

勢いに乗って、OSPFのキャプチャーを始めた・・。




荒:では、BGPもRIPも無事動きましたので、
  OSPFに戻ります。

  OSPFの基本となる、
  Helloパケットを見ながら、
  ネイバーテーブルも見てみましょう。


奥:今日から、パケットキャプチャーも行います。

  キャプチャーには、
  Wireshark(ワイヤーシャーク)を使います。


  以前は、Ethereal(イーサーリアル)と呼ばれてました。


  http://www.wireshark.org/
  Wiresharkの本家サイトです。

  ここからリンクをたどり、ダウンロードできますよ。



荒:準備OKですね。

奥:最初に、ホスト名:bind1 だけ起動します。


ospfhello.GIF


奥:Helloを10秒間隔で送信してますね。

荒:そう。

  OSPFを話しているんだ、

  と、自ら名乗り出ている、
  これが、大事なところだと思います。


  「こんにちは、俺とネイバー関係になろう!
   アジャセンシー やろうぜ!」

   って感じですね。


奥:10秒ごとに、声をかけているというナンパチックな
  プロトコルですねー。

荒:そうそう。

  そういう意味で言うと、RIPより積極的とも言えるなぁー(^^)。


奥:じゃあ、今度、プロトコルごとの「積極さ順位」を
  まとめますか?わーい(嬉しい顔)


  さてさて、次は、ネイバーテーブルを見ましょう。

  今は、1台しか起動させてないんですが、
  一応、見ましょう。



bind1# show ip ospf neighbor

Neighbor ID Pri State Dead Time Address Interface RXmtL RqstL DBsmL

(何もなし)



荒:ということですね。

  明日は、ホスト名:redhat が登場するとどうなるか?

  redhatが、いなくなるとどうなるか、

  を見てみましょう。


奥:はい。

  それでは、また明日。(^^)/~ (^^)/~




■参考
「パケットキャプチャ入門―LANアナライザWireshark活用術」

http://homepage3.nifty.com/sysaho/ccnp.html

特にネットワークエンジニアを目指す人は、
キャプチャーって当たり前のように、行えるように。

この本は、日経BP社の講習などを担当されていた方なので、
簡潔にわかりやすく書かれています。


「要点解説 IPルーティング入門」(P176〜,P179〜)
「とこトンやさしいIPルーティング」(P237〜)


posted by アンドレアス at 21:06| OSPFを動かす | このブログの読者になる | 更新情報をチェックする

2007年05月10日

OSPFの基本設定3

■構成図(同じです)

ホスト名:bind1
eth0: 192.168.1.14/24
|
|
スイッチングハブ
|
|
eth0: 192.168.1.101/24
ホスト名:redhat eth2:192.168.3.101/24
eth1: 192.168.2.101/24
|
|





荒:さっそく、始めましょう。

  まとめ、をやるつもりでしたが、
  もう少し、基本コマンドを使ってからにします。

奥:はい。


荒:最初に、ホスト名 redhat と bind1 の
  ルーティングテーブルを確認しましょう。


奥:はい。昨日のままですね。

  誰も触ってないようですね。(^^)



redhat.example.com# show ip route
Codes: K - kernel route, C - connected, S - static, R - RIP, O - OSPF,
I - ISIS, B - BGP, > - selected route, * - FIB route

K>* 0.0.0.0/0 via 192.168.1.1, eth0
C>* 127.0.0.0/8 is directly connected, lo
O 192.168.1.0/24 [110/10] is directly connected, eth0, 00:03:01
C>* 192.168.1.0/24 is directly connected, eth0
O 192.168.2.0/24 [110/10] is directly connected, eth1, 00:03:01
C>* 192.168.2.0/24 is directly connected, eth1
C>* 192.168.3.0/24 is directly connected, eth2


bind1.example.com# show ip route
Codes: K - kernel route, C - connected, S - static, R - RIP, O - OSPF,
I - ISIS, B - BGP, > - selected route, * - FIB route

K>* 0.0.0.0/0 via 192.168.1.1, eth0
C>* 127.0.0.0/8 is directly connected, lo
O 192.168.1.0/24 [110/10] is directly connected, eth0, 00:16:27
C>* 192.168.1.0/24 is directly connected, eth0
O>* 192.168.2.0/24 [110/20] via 192.168.1.101, eth0, 00:04:43


荒:ネイバーテーブルも確認して下さい。

奥:はい。


redhat# show ip ospf neighbor

Neighbor ID Pri State Dead Time Address Interface RXmtL RqstL DBsmL
192.168.1.14 1 Full/DR 00:00:35 192.168.1.14 eth0:192.168.1.101 0 0 0
redhat#

bind1# show ip ospf neighbor

Neighbor ID Pri State Dead Time Address Interface RXmtL RqstL DBsmL
192.168.1.101 1 Full/Backup 00:00:35 192.168.1.101 eth0:192.168.1.14 0 0 0


荒:ブログだと見にくいですが、
  自分でquaggaを動かして確認したり、
  書籍で確認しておきましょう。

奥:quaggaでは、Backupって出るんですね。

荒:そうですね。

  さっき、見てたんだけど、
  CiscoルーターだとBDRという表示でしたよね。

  BDRのBが、BackupのBなので、意味は一緒です。


奥:なるほど。

  Backup Designated Routerですね。

荒:では、必須コマンドをうってください。


奥:えっと、これですね。


redhat# show ip ospf database

OSPF Router with ID (192.168.1.101)

Router Link States (Area 0.0.0.0)

Link ID ADV Router Age Seq# CkSum Link count
192.168.1.14 192.168.1.14 917 0x80000003 0xdd88 1
192.168.1.101 192.168.1.101 879 0x80000003 0x7169 2

Net Link States (Area 0.0.0.0)

Link ID ADV Router Age Seq# CkSum
192.168.1.14 192.168.1.14 918 0x80000001 0xb967




bind1# show ip ospf database

OSPF Router with ID (192.168.1.14)

Router Link States (Area 0.0.0.0)

Link ID ADV Router Age Seq# CkSum Link count
192.168.1.14 192.168.1.14 930 0x80000003 0xdd88 1
192.168.1.101 192.168.1.101 892 0x80000003 0x7169 2

Net Link States (Area 0.0.0.0)

Link ID ADV Router Age Seq# CkSum
192.168.1.14 192.168.1.14 930 0x80000001 0xb967


奥:トポロジーデータベースが、これですね。

荒:後から、エリア1とか追加していきますので。


奥:今度の必須コマンドは、これですね。



bind1# show ip ospf interface eth0
eth0 is up
Internet Address 192.168.1.14/24, Broadcast 192.168.1.255, Area 0.0.0.0
Router ID 192.168.1.14, Network Type BROADCAST, Cost: 10
Transmit Delay is 1 sec, State DR, Priority 1
Designated Router (ID) 192.168.1.14, Interface Address 192.168.1.14
Backup Designated Router (ID) 192.168.1.101, Interface Address 192.168.1.101
Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
Hello due in 00:00:03
Neighbor Count is 1, Adjacent neighbor count is 1


荒:まあ、知っておくと便利なコマンドです。

  このインターフェースで、OSPFが動いているとか
  DRは、どのルーターだとか、色々わかります。

  ネイバーの数、アジャセンシーの数なんかも
  気がつくと、なお良いですよ。

  ネイバー・アジャセンシーともに
  必須用語です。


  では、1つネイバーを増やしてみます。


奥:IPアドレスが、192.168.1.33/24。

  ホスト名:qmail1 を起動させました。


  ネイバーテーブルを見ると、正常動作してるようです。



qmail1# show ip ospf neighbor

Neighbor ID Pri State Dead Time Address Interface RXmtL RqstL DBsmL
192.168.1.14 1 Full/DR 00:00:35 192.168.1.14 eth0:192.168.1.33 0 0 0
192.168.1.101 1 Full/Backup 00:00:36 192.168.1.101 eth0:192.168.1.33 0 0 0
qmail1#


荒:bind1で、もう1回ネイバーテーブルを見て下さい。

  qmail1が、DROtherになってるはずです。


奥:本当ですね。


bind1# show ip ospf neighbor

Neighbor ID Pri State Dead Time Address Interface RXmtL RqstL DBsmL
192.168.1.33 1 Full/DROther 00:00:30 192.168.1.33 eth0:192.168.1.14 0 0 0
192.168.1.101 1 Full/Backup 00:00:38 192.168.1.101 eth0:192.168.1.14 0 0 0



荒:同一セグメント(192.168.1.0/24)内で、
  DR・BDR・DROtherという3つの役割があるということが
  わかってもらえたと思います。

奥:もう1台増えると、DROtherですか?

荒:はい。

奥:さらにもう1台増えても?

荒:はい。

奥:なるほど、ありがとうございました。

  では、保存しておきますね。


荒:明日は、何しようかな。

  キャプチャーしようか。

  RIPかBGPしようか・・・。


奥:OSPFのキャプチャーがいいです。

  Helloパケットとか見たいです。

荒:じゃあ、そうしましょう。


============================================
■参考
「要点解説 IPルーティング入門」P246〜
「とこトンやさしいIPルーティング」P162,P170〜

 http://homepage3.nifty.com/sysaho/ccnp.html
posted by アンドレアス at 20:11| Comment(0) | TrackBack(0) | OSPFを動かす | このブログの読者になる | 更新情報をチェックする

2007年05月09日

OSPFの基本設定2

荒:さて、昨日まで bind1というホスト名のマシンで、
  OSPFを動かしました。

  今日から、redhat というホスト名のマシンを追加します。




■構成図

ホスト名:bind1
eth0: 192.168.1.14/24
|
|
スイッチングハブ
|
|
eth0: 192.168.1.101/24
ホスト名:redhat eth2:192.168.3.101/24
eth1: 192.168.2.101/24
|
|



荒:今度、Visioで、ちゃんと構成図作成しようか?


奥:そうですね。

  ちゃんとした構成図作らないと
  私達が、わからなくなりそうですね。
 

荒:竹内君に作ってもらうか(^^)。

奥:ちなみに、このマシンは3つのLANカードがあります。

荒:redhatのeth0,eth1両方のインターフェースで
  OSPFを動かします。

  192.168.2.0/24の経路情報が、
  bind1に、伝わる様子を
  あなた自身の目で確認して下さい。


奥:やっと、OSPFらしく、
  ダイナミックルーティングができますね。

荒:じゃあ、奥田さん、どうぞ!


奥:了解!

  皆さんは、redhatでも、
  bind1同様の設定準備を行って下さい。

  わからない人は、過去ブログを見直して下さいね。


荒:明日、今週のまとめ、をやりましょうか。


奥:はい、それいいですね。

  zebra.conf、ospfd.confを
  昨日までと同じ設定を、完了したところから、
  始めます。




[root@redhat quagga]# telnet 127.0.0.1 2604
Trying 127.0.0.1...
Connected to redhat.example.com (127.0.0.1).
Escape character is '^]'.

Hello, this is Quagga (version 0.98.6).
Copyright 1996-2005 Kunihiro Ishiguro, et al.


User Access Verification

Password: <-- 123
redhat> en
Password: <-- 123
redhat# conf t

redhat(config)# router ospf

redhat(config-router)# network 192.168.1.0/24 area 0
redhat(config-router)# network 192.168.2.0/24 area 0

redhat(config-router)# end
redhat#



荒:じゃあ、bind1側を見てみましょう。

  2601番ポート、ゼブラのルーティングテーブルに
  変化が出ています。

[root@bind1 quagga]# telnet 127.0.0.1 2601
Trying 127.0.0.1...
Connected to bind1.example.com (127.0.0.1).
Escape character is '^]'.

Hello, this is Quagga (version 0.98.6).
Copyright 1996-2005 Kunihiro Ishiguro, et al.


User Access Verification

Password:
localhost.localdomain> en
Password:

localhost.localdomain# show ip route
Codes: K - kernel route, C - connected, S - static, R - RIP, O - OSPF,
I - ISIS, B - BGP, > - selected route, * - FIB route

K>* 0.0.0.0/0 via 192.168.1.1, eth0
C>* 127.0.0.0/8 is directly connected, lo
K>* 169.254.0.0/16 is directly connected, eth0
C>* 192.168.1.0/24 is directly connected, eth0
O>* 192.168.2.0/24 [110/20] via 192.168.1.101, eth0, 00:22:08 



奥:おおーー。

  すごい手(チョキ)

  いったん、zebraからexitして pingをうってみます。


  

[root@bind1 quagga]# ping 192.168.2.101
PING 192.168.2.101 (192.168.2.101) 56(84) bytes of data.
64 bytes from 192.168.2.101: icmp_seq=1 ttl=64 time=5.12 ms
64 bytes from 192.168.2.101: icmp_seq=2 ttl=64 time=0.725 ms
64 bytes from 192.168.2.101: icmp_seq=3 ttl=64 time=0.726 ms
64 bytes from 192.168.2.101: icmp_seq=4 ttl=64 time=0.806 ms


荒:OK。

  これで大丈夫ですね。

  じゃあ、bind1とredhat、
  両方のマシンで、
  show ip ospf neighbor コマンドをうって下さい。


  今日はこれで、おしまいです。


奥:はい。

  最初は、redhatの方で、コマンドうちます。


redhat# show ip ospf neighbor

Neighbor ID Pri State Dead Time Address Interface RXmtL RqstL DBsmL
192.168.1.14 1 Full/DR 00:00:36 192.168.1.14 eth0:192.168.1.101 0 0 0


bind1# show ip ospf neighbor

Neighbor ID Pri State Dead Time Address Interface RXmtL RqstL DBsmL
192.168.1.101 1 Full/Backup 00:00:35 192.168.1.101 eth0:192.168.1.14 0 0 0



荒:これが、ネイバーテーブルです。

  コマンドも必須です。

  これを見て、どのルーターが
  どういう役割なのか、把握できます。


  DRとかBackupとかFullって用語は、必須知識です。


奥:うーーん。

  ここに書いている通りですねぇー。


■参考
「要点解説 IPルーティング入門」P245〜
「とこトンやさしいIPルーティング」P170〜

 http://homepage3.nifty.com/sysaho/ccnp.html




荒:最後に この設定を保存しておきましょう。

  これ、ホンマに良くできてるなぁー。


redhat# copy running-config startup-config
Configuration saved to /etc/quagga/ospfd.conf


bind1# copy running-config startup-config
Configuration saved to /etc/quagga/ospfd.conf



荒:じゃあ、また明日。手(パー)

奥:ありがとうございました。

  どんどん、進みますねぇー。わーい(嬉しい顔)

posted by アンドレアス at 21:55| Comment(0) | TrackBack(0) | OSPFを動かす | このブログの読者になる | 更新情報をチェックする

2007年05月08日

OSPFの基本設定1

荒:どう?

  動いた?

奥:はい。

  簡単なレベルですけど。

荒:じゃあ、始めましょうか。


(太字部分が、手入力です)


[root@bind1 ~]# telnet 127.0.0.1 ospfd

Hello, this is Quagga (version 0.98.6).
Copyright 1996-2005 Kunihiro Ishiguro, et al.


User Access Verification

Password: <--123と入力
bind1> en
Password: <--123と入力

bind1# conf t
bind1(config)#


奥:これで準備できました。

荒:では、奥田さんは復習になりますが、
  下記のように入力してください。


(太字を手入力)
bind1(config)# router ospf
bind1(config-router)# network 192.168.1.0/24 area 0


奥:できました。

  exit でいいですか?

荒:end でいいよ。

奥:end ?

  おーっ!一気に抜けました。

  なるほど。

荒:これも覚えておくと便利です。

  CCNAレベルの書籍には、必ず出てますよ。

  さて、ずいぶん前にメルマガで言いましたが、
  これが最低レベルのOSPF設定ですね。


  Ciscoとの違いは、覚えてますか?


奥:えっと、
  Ciscoルーターだと、

  router ospf 100とか言う具合に

  任意で、プロセスIDを、数字入力しますけど、
  quaggaは何も入力しない、です。


荒:そうそう。

  CCNAやCCNP受験する人は、
  間違わないように注意して下さい。


  もう1つあります。

  networkコマンドのところを見てください。

  Ciscoは、ワイルドカードマスクですけど、
  quaggaは、/24みたいな設定ですね。

  これも注意して下さい。

  まあ、奥田さんなら、大丈夫でしょう。


奥:後で、Ciscoルーターも触っておきます。


荒:じゃあ、最後に確認してみましょう。


  既に、/etc/rc.d/init.d/zebra startしてますよね。

  なので、quagga(2601番ポート)に
  telnetして下さい。



[root@bind1 ~]# telnet 127.0.0.1 2601
Trying 127.0.0.1...
Connected to bind1.example.com (127.0.0.1).
Escape character is '^]'.

Hello, this is Quagga (version 0.98.6).
Copyright 1996-2005 Kunihiro Ishiguro, et al.


User Access Verification

Password: <--123と入力

localhost.localdomain> en

Password: <--123と入力

localhost.localdomain#


荒:show ip routeして、今日はおしまいです。

奥:はい。



localhost.localdomain# show ip route
Codes: K - kernel route, C - connected, S - static, R - RIP, O - OSPF,
I - ISIS, B - BGP, > - selected route, * - FIB route

K>* 0.0.0.0/0 via 192.168.1.1, eth0
C>* 127.0.0.0/8 is directly connected, lo
K>* 169.254.0.0/16 is directly connected, eth0
O 192.168.1.0/24 [110/10] is directly connected, eth0, 00:11:09
C>* 192.168.1.0/24 is directly connected, eth0


奥:おお。

  OSPFの経路が、出てきましたね。


荒:明日は、もう1台追加しましょうか。

奥:はい。

  いよいよ本格的にルーティング環境が
  できそうですね。





■参考
「要点解説 IPルーティング入門」P229〜
「とこトンやさしいIPルーティング」P218〜

 http://homepage3.nifty.com/sysaho/ccnp.html



CCNP受験・CCNA受験、両方に使えます。


初心者・新入社員の人が、
基礎的なことを学ぶためにも
非常に良い、わかりやすい本です。


★★★★★超オススメですよー。

posted by アンドレアス at 23:33| Comment(0) | TrackBack(0) | OSPFを動かす | このブログの読者になる | 更新情報をチェックする

2007年05月07日

OSPFデーモン(ospfd)の起動

奥:早いですね。(^^)

荒:僕らは、ペース速いね(^^)。

  では、OSPFを動かします。

  少し、事前説明をしますね。


1.OSPFデーモンの起動

  /etc/rc.d/init.d/ospfd start

2.OSPF設定ファイル

  /etc/quagga/ospfd.conf

  ospfd.conf.sampleをコピーして、
  作っておきましょう。


(ospfd.confの内容)
! -*- ospf -*-
!
! OSPFd sample configuration file
!
!
hostname bind1
password 123
enable password 123

!
!router ospf
! network 192.168.1.0/24 area 0
!
log stdout


※hostnameとかパスワードは、
 あまり気にせず、適当に。


3.telnetするとき

  telnet 127.0.0.1 ospfd

  あるいは、

  telnet 127.0.0.1 2604


※quaggaは、実は2601番ポートに接続していました。
 気づいてましたか?

 

荒:さて、これだけ説明しておきます。

  既にCisco本を買った「やる気のある人」

  既にCiscoルーターを触ったことある人は、
  OSPF設定を始めることができるだろうと
  思います。


  奥田さんは、早速始めたようですねわーい(嬉しい顔)


奥:じゃあ、この続きは、また明日。

  早いですねぇー。


  (CCNAを目指す人へ、参考書籍ですよ)
  http://homepage3.nifty.com/sysaho/ccna.html
posted by アンドレアス at 21:25| Comment(0) | TrackBack(0) | OSPFを動かす | このブログの読者になる | 更新情報をチェックする

広告


この広告は60日以上更新がないブログに表示がされております。

以下のいずれかの方法で非表示にすることが可能です。

・記事の投稿、編集をおこなう
・マイブログの【設定】 > 【広告設定】 より、「60日間更新が無い場合」 の 「広告を表示しない」にチェックを入れて保存する。